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Active Directory 診断テンプレートで Perfmon.exe を実行してドメイン コントローラーでレポートを生成すると、レポート生成プロセスが応答しなくなる場合があります

この記事では、Active Directory 診断テンプレートを使用してレポートを生成する Perfmon.exe を実行すると、レポート生成プロセスの応答が停止する問題を解決するためのヘルプを提供します。

元の KB 番号: 971714

症状

Active Directory 診断テンプレートを使用して Perfmon.exe を実行して Windows Server ドメイン コントローラーにレポートを生成すると、プロセスが応答しなくなる可能性があります。

原因

この問題は、TraceRpt.exe ツールを実行している信頼性とパフォーマンス モニター (Perfmon.exe) コンソールが、レポート生成プロセス中に消費されるメモリと CPU リソースが多すぎるために発生します。 Windows Server がビジー状態でリソースがない場合、レポート生成プロセスは応答を停止します。

解決策

この問題を解決するには、同じサーバーの役割を持ち、ハードウェア リソースが十分にある別のコンピューターにファイルをコピーします。 次に、ファイルを使用して TraceRpt.exe を実行します。 この手順を実行するには、以下のステップに従ってください。

  1. 信頼性とパフォーマンス モニター (Perfmon.exe) コンソールで、[ データ コレクター セット] をクリックし、[ システム] をクリックします。

  2. Active Directory Diagnosticsを右クリックし、[開始] をクリックします。 ファイル収集プロセスは、Windows Server ドメイン コントローラーで開始されます。

  3. レポートの状態がデータの収集<時間>** からレポートの生成に変わったら、2番目の Windows Server ドメイン コントローラーにファイルをコピーします。

    ファイルは、次の場所にあります: %systemdrive%\Perflogs\ADDS\ 日付レポート作成実行 \*

    "-df" スイッチは、Perfmon で生成される Microsoft 固有のカウント/レポート スキーマ ファイルを指定することです。 このファイル名は report.xsl という名前です。

  4. ファイルを見つけて、2 番目の Windows Server ドメイン コントローラーのコマンド ラインで次のコマンドを実行します。

    tracerpt *.blg *.etl -df *PerfmonSchemaFileName.xsl* -report *your_report.html* -f html **** ****
    
  5. Windows Internet Explorer を使用して、生成された .html ファイルを表示します。